aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-12-16 02:11:07 +0100
committerPřemysl Eric Janouch <p@janouch.name>2022-06-10 02:18:14 +0200
commit81145064de936e9ec401a50deca315891c6068f0 (patch)
treed0060c36073a6ee79e8f8c6dcdb21c0fa8c1f444 /meson.build
parent60a8ee7a80063eaf620eaa727af0f484fdb91bff (diff)
downloadfiv-81145064de936e9ec401a50deca315891c6068f0.tar.gz
fiv-81145064de936e9ec401a50deca315891c6068f0.tar.xz
fiv-81145064de936e9ec401a50deca315891c6068f0.zip
Generate TIFF structs/enums from a text file
This is to make the tables much easier to maintain.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a33cbd7..c511d6a 100644
--- a/meson.build
+++ b/meson.build
@@ -96,6 +96,13 @@ resources = gnome.compile_resources('resources',
c_name : 'resources',
)
+tiff_tables = custom_target('tiff-tables.h',
+ output : 'tiff-tables.h',
+ input : 'tiff-tables.db',
+ command : ['tiff-tables.awk', '@INPUT@'],
+ capture : true,
+)
+
exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-io.c',
'fiv-browser.c', 'fiv-sidebar.c', 'fiv-thumbnail.c', 'xdg.c', resources,
install : true,
@@ -122,7 +129,7 @@ if get_option('tools').enabled()
tools_c_args = cc.get_supported_arguments(
'-Wno-unused-function', '-Wno-unused-parameter')
foreach tool : ['pnginfo', 'jpeginfo', 'tiffinfo', 'webpinfo', 'bmffinfo']
- executable(tool, 'tools/' + tool + '.c',
+ executable(tool, 'tools/' + tool + '.c', tiff_tables,
dependencies : tools_dependencies,
c_args: tools_c_args)
endforeach