aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-06-10 01:16:14 +0200
committerPřemysl Eric Janouch <p@janouch.name>2022-06-10 02:08:56 +0200
commit60a8ee7a80063eaf620eaa727af0f484fdb91bff (patch)
tree5791554d3691a6a8cd903123d77725d3b3dd7756 /meson.build
parent84f8c9436ffb84ca5d443b906f1ffb7be42a50e2 (diff)
downloadfiv-60a8ee7a80063eaf620eaa727af0f484fdb91bff.tar.gz
fiv-60a8ee7a80063eaf620eaa727af0f484fdb91bff.tar.xz
fiv-60a8ee7a80063eaf620eaa727af0f484fdb91bff.zip
Build tools with Meson as well
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b885e2e..a33cbd7 100644
--- a/meson.build
+++ b/meson.build
@@ -115,6 +115,19 @@ jpegcrop = executable('fiv-jpegcrop', 'fiv-jpegcrop.c',
install_data('fiv-jpegcrop.desktop',
install_dir : get_option('datadir') / 'applications')
+if get_option('tools').enabled()
+ # libjq 1.6 lacks a pkg-config file, and there is no release in sight.
+ # libjq 1.6 is required.
+ tools_dependencies = [cc.find_library('libjq'), dependency('libpng')]
+ tools_c_args = cc.get_supported_arguments(
+ '-Wno-unused-function', '-Wno-unused-parameter')
+ foreach tool : ['pnginfo', 'jpeginfo', 'tiffinfo', 'webpinfo', 'bmffinfo']
+ executable(tool, 'tools/' + tool + '.c',
+ dependencies : tools_dependencies,
+ c_args: tools_c_args)
+ endforeach
+endif
+
# XXX: With gdk-pixbuf, this even depends on currently installed modules.
if meson.is_cross_build()
install_data('fiv.desktop',