aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-14 21:28:44 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-14 21:28:44 +0100
commitc5dbe5fa44d808b95e55b6eb12e11bc32267dafe (patch)
tree40d9bcdb6980067c11c6ca7514230560e862e7ca /CMakeLists.txt
parent7e5e66073747e3949be37ee1da462f9028c98a6e (diff)
downloadtdv-c5dbe5fa44d808b95e55b6eb12e11bc32267dafe.tar.gz
tdv-c5dbe5fa44d808b95e55b6eb12e11bc32267dafe.tar.xz
tdv-c5dbe5fa44d808b95e55b6eb12e11bc32267dafe.zip
Don't force compilation flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47ed206..2ab65ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "-std=gnu99")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
set (CMAKE_C_FLAGS_DEBUG
"${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-missing-field-initializers")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)