From c5dbe5fa44d808b95e55b6eb12e11bc32267dafe Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Mon, 14 Mar 2016 21:28:44 +0100
Subject: Don't force compilation flags
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
(limited to 'CMakeLists.txt')
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47ed206..2ab65ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "-std=gnu99")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
set (CMAKE_C_FLAGS_DEBUG
"${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-missing-field-initializers")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
--
cgit v1.2.3-70-g09d2