aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-12-21 07:59:44 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-12-21 07:59:44 +0100
commitc9b003735df3a2dcd65e89a19c174f1dac4aeb23 (patch)
treeea95b4255ae6af5445a7b47a5aebf582743f9300 /CMakeLists.txt
parent52a28f01c8dc2a1a257e7f3d49ca2e35574edf06 (diff)
downloadsdn-c9b003735df3a2dcd65e89a19c174f1dac4aeb23.tar.gz
sdn-c9b003735df3a2dcd65e89a19c174f1dac4aeb23.tar.xz
sdn-c9b003735df3a2dcd65e89a19c174f1dac4aeb23.zip
Fix OpenBSD build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e61315..bb3b619 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,12 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
endif ()
find_package (PkgConfig REQUIRED)
-pkg_check_modules (NCURSESW REQUIRED ncursesw)
pkg_check_modules (ACL libacl)
+pkg_check_modules (NCURSESW ncursesw)
+if (NOT NCURSESW_FOUND)
+ find_library (NCURSESW_LIBRARIES NAMES ncursesw)
+ find_path (NCURSESW_INCLUDE_DIRS ncurses.h PATH_SUFFIXES ncurses)
+endif ()
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.cpp)
target_include_directories (${PROJECT_NAME} PUBLIC ${NCURSESW_INCLUDE_DIRS})