aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-12-21 07:37:06 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-12-21 07:37:06 +0100
commit52a28f01c8dc2a1a257e7f3d49ca2e35574edf06 (patch)
tree27cfecc9c729a0bf703518aa28b45d838a5750aa /CMakeLists.txt
parent360775755401340f7e2b41cdc8d1fc9fd1d16feb (diff)
downloadsdn-52a28f01c8dc2a1a257e7f3d49ca2e35574edf06.tar.gz
sdn-52a28f01c8dc2a1a257e7f3d49ca2e35574edf06.tar.xz
sdn-52a28f01c8dc2a1a257e7f3d49ca2e35574edf06.zip
Add support for BSD derivatives, fix macOS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50ebf3b..4e61315 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,11 +8,13 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
endif ()
find_package (PkgConfig REQUIRED)
-pkg_check_modules (NCURSESW QUIET ncursesw)
+pkg_check_modules (NCURSESW REQUIRED ncursesw)
+pkg_check_modules (ACL libacl)
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.cpp)
target_include_directories (${PROJECT_NAME} PUBLIC ${NCURSESW_INCLUDE_DIRS})
-target_link_libraries (${PROJECT_NAME} PUBLIC ${NCURSESW_LIBRARIES} acl)
+target_link_libraries (${PROJECT_NAME}
+ PUBLIC ${NCURSESW_LIBRARIES} ${ACL_LIBRARIES})
target_compile_features (${PROJECT_NAME} PUBLIC cxx_std_14)
target_compile_definitions (${PROJECT_NAME} PUBLIC
-DPROJECT_NAME=\"${PROJECT_NAME}\" -DPROJECT_VERSION=\"${PROJECT_VERSION}\")