aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-12-21 16:43:03 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-12-21 16:57:43 +0100
commit85b2d8a2ee966794768f26cfc2404c850d33e096 (patch)
tree0947b4c330ef21d46503ed49e9ac7d42c926cb4f /CMakeLists.txt
parent272ee62ad8a3f2e4aa0756ae76f0672c5b65a9be (diff)
downloadsdn-85b2d8a2ee966794768f26cfc2404c850d33e096.tar.gz
sdn-85b2d8a2ee966794768f26cfc2404c850d33e096.tar.xz
sdn-85b2d8a2ee966794768f26cfc2404c850d33e096.zip
Use more of the relevant pkg-config variablesHEADorigin/mastermaster
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78f13a4..87e5206 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,10 @@ if (NOT NCURSESW_FOUND)
endif ()
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.cpp)
-target_include_directories (${PROJECT_NAME} PUBLIC ${NCURSESW_INCLUDE_DIRS})
+target_include_directories (${PROJECT_NAME}
+ PUBLIC ${NCURSESW_INCLUDE_DIRS} ${ACL_INCLUDE_DIRS})
+target_link_directories (${PROJECT_NAME}
+ PUBLIC ${NCURSESW_LIBRARY_DIRS} ${ACL_LIBRARY_DIRS})
target_link_libraries (${PROJECT_NAME}
PUBLIC ${NCURSESW_LIBRARIES} ${ACL_LIBRARIES})
target_compile_features (${PROJECT_NAME} PUBLIC cxx_std_14)