aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-01-18 04:07:05 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-01-18 04:14:45 +0100
commiteb0f8a028cf7ddb1b708ee97e6a9c777b45d4d4f (patch)
treed923be9e25130cec96209be2fb6db4668c7b16a6 /CMakeLists.txt
parent7cb6fcdaff2237cd24cf22fbc739192704838b6d (diff)
downloadponymap-eb0f8a028cf7ddb1b708ee97e6a9c777b45d4d4f.tar.gz
ponymap-eb0f8a028cf7ddb1b708ee97e6a9c777b45d4d4f.tar.xz
ponymap-eb0f8a028cf7ddb1b708ee97e6a9c777b45d4d4f.zip
Implement a Lua 5.3 plugin loader plugin
Also implemented SOCKS detection in said language. There are probably going to be some bugs. The program is no longer Valgrind-clean, as that would require plugin deinitialization, in which there is very little point.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea214e2..57d04ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,7 +73,11 @@ set_target_properties (plugin-http PROPERTIES OUTPUT_NAME http PREFIX "")
install (TARGETS plugin-http DESTINATION ${plugin_dir})
# Build the other plugins
-foreach (plugin irc ssh)
+set (plugins irc ssh)
+if (WITH_LUA)
+ list (APPEND plugins lua-loader)
+endif (WITH_LUA)
+foreach (plugin ${plugins})
set (target plugin-${plugin})
add_library (${target} SHARED plugins/${plugin}.c plugin-api.h)
target_link_libraries (${target} ${project_libraries})