aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-01-17 15:54:49 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-01-17 16:10:12 +0100
commit7cb6fcdaff2237cd24cf22fbc739192704838b6d (patch)
treecedd22bc2e220d69212b06683b12025dc3814e1e /CMakeLists.txt
parent77509ceb56d430d949a89f2fc25aaded414193a8 (diff)
downloadponymap-7cb6fcdaff2237cd24cf22fbc739192704838b6d.tar.gz
ponymap-7cb6fcdaff2237cd24cf22fbc739192704838b6d.tar.xz
ponymap-7cb6fcdaff2237cd24cf22fbc739192704838b6d.zip
Rewrite to use CMake
Now the project is at least installable. Added a LICENSE file. Likely about to implement Lua plugins.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt125
1 files changed, 125 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ea214e2
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,125 @@
+project (ponymap C)
+cmake_minimum_required (VERSION 2.8.5)
+
+# Moar warnings
+if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+ # -Wunused-function is pretty annoying here, as everything is static
+ set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
+endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+
+# Build options
+option (WITH_LUA "Enable experimental support for Lua 5.3 plugins" ON)
+
+# Version
+set (project_VERSION_MAJOR "0")
+set (project_VERSION_MINOR "1")
+set (project_VERSION_PATCH "0")
+
+set (project_VERSION "${project_VERSION_MAJOR}")
+set (project_VERSION "${project_VERSION}.${project_VERSION_MINOR}")
+set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
+
+# Dependencies
+find_package (Curses)
+find_package (PkgConfig REQUIRED)
+pkg_check_modules (jansson REQUIRED jansson)
+pkg_check_modules (libssl REQUIRED libssl)
+pkg_check_modules (ncursesw ncursesw)
+
+if (ncursesw_FOUND)
+ set (project_libraries ${ncursesw_LIBRARIES})
+ include_directories (${ncursesw_INCLUDE_DIRS})
+elseif (CURSES_FOUND)
+ set (project_libraries ${CURSES_LIBRARY})
+ include_directories (${CURSES_INCLUDE_DIR})
+else (CURSES_FOUND)
+ message (SEND_ERROR "Curses not found")
+endif (ncursesw_FOUND)
+
+if (WITH_LUA)
+ pkg_search_module (lua REQUIRED lua5.3 lua-5.3 lua=5.3)
+ list (APPEND project_libraries ${lua_LIBRARIES})
+ include_directories (${lua_INCLUDE_DIRS})
+endif (WITH_LUA)
+
+# -lpthread is only there for debugging (gdb & errno)
+# -lrt is only for glibc < 2.17
+list (APPEND project_libraries
+ ${libssl_LIBRARIES} ${jansson_LIBRARIES} rt dl pthread)
+include_directories (${libssl_INCLUDE_DIRS} ${jansson_INCLUDE_DIRS})
+
+# Project source files
+set (project_sources ${PROJECT_NAME}.c siphash.c)
+set (project_headers ${PROJECT_BINARY_DIR}/config.h)
+
+# Generate a configuration file
+include (GNUInstallDirs)
+set (plugin_dir ${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME})
+configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
+include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
+
+# Build and install the main executable
+add_executable (${PROJECT_NAME} ${project_sources} ${project_headers})
+target_link_libraries (${PROJECT_NAME} ${project_libraries})
+
+install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
+install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
+
+# Build the HTTP plugin
+add_library (plugin-http SHARED plugins/http.c plugin-api.h
+ http-parser/http_parser.c http-parser/http_parser.h)
+target_link_libraries (plugin-http ${project_libraries})
+set_target_properties (plugin-http PROPERTIES OUTPUT_NAME http PREFIX "")
+install (TARGETS plugin-http DESTINATION ${plugin_dir})
+
+# Build the other plugins
+foreach (plugin irc ssh)
+ set (target plugin-${plugin})
+ add_library (${target} SHARED plugins/${plugin}.c plugin-api.h)
+ target_link_libraries (${target} ${project_libraries})
+ set_target_properties (${target} PROPERTIES OUTPUT_NAME ${plugin} PREFIX "")
+ install (TARGETS ${target} DESTINATION ${plugin_dir})
+endforeach (plugin)
+
+# Generate documentation from program help
+find_program (HELP2MAN_EXECUTABLE help2man)
+if (NOT HELP2MAN_EXECUTABLE)
+ message (FATAL_ERROR "help2man not found")
+endif (NOT HELP2MAN_EXECUTABLE)
+
+foreach (page ${PROJECT_NAME})
+ set (page_output "${PROJECT_BINARY_DIR}/${page}.1")
+ list (APPEND project_MAN_PAGES "${page_output}")
+ add_custom_command (OUTPUT ${page_output}
+ COMMAND ${HELP2MAN_EXECUTABLE} -N
+ "${PROJECT_BINARY_DIR}/${page}" -o ${page_output}
+ DEPENDS ${PROJECT_NAME}
+ COMMENT "Generating man page for ${page}" VERBATIM)
+endforeach (page)
+
+add_custom_target (docs ALL DEPENDS ${project_MAN_PAGES})
+
+foreach (page ${project_MAN_PAGES})
+ string (REGEX MATCH "\\.([0-9])" manpage_suffix "${page}")
+ install (FILES "${page}"
+ DESTINATION "${CMAKE_INSTALL_MANDIR}/man${CMAKE_MATCH_1}")
+endforeach (page)
+
+# CPack
+set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Experimental network scanner")
+set (CPACK_PACKAGE_VERSION ${project_VERSION})
+set (CPACK_PACKAGE_VENDOR "Premysl Janouch")
+set (CPACK_PACKAGE_CONTACT "Přemysl Janouch <p.janouch@gmail.com>")
+set (CPACK_RESOURCE_FILE_LICENSE "${PROJECT_SOURCE_DIR}/LICENSE")
+
+set (CPACK_GENERATOR "TGZ;ZIP")
+set (CPACK_PACKAGE_FILE_NAME
+ "${PROJECT_NAME}-${project_VERSION}-${CMAKE_SYSTEM_NAME}-${CMAKE_SYSTEM_PROCESSOR}")
+set (CPACK_PACKAGE_INSTALL_DIRECTORY "${PROJECT_NAME}-${project_VERSION}")
+
+set (CPACK_SOURCE_GENERATOR "TGZ;ZIP")
+set (CPACK_SOURCE_IGNORE_FILES "/\\\\.git;/build;/CMakeLists.txt.user")
+set (CPACK_SOURCE_PACKAGE_FILE_NAME "${PROJECT_NAME}-${project_VERSION}")
+
+set (CPACK_SET_DESTDIR TRUE)
+include (CPack)