aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-01-21 00:06:26 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-01-21 00:06:26 +0100
commit45595157e8f0b655767fdccfc6a1c194897fe8b0 (patch)
tree666552fb880c25ba8bc29cd108b2cacf3fa570cc /CMakeLists.txt
parenteb0f8a028cf7ddb1b708ee97e6a9c777b45d4d4f (diff)
downloadponymap-45595157e8f0b655767fdccfc6a1c194897fe8b0.tar.gz
ponymap-45595157e8f0b655767fdccfc6a1c194897fe8b0.tar.xz
ponymap-45595157e8f0b655767fdccfc6a1c194897fe8b0.zip
Fix Lua detection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57d04ba..9cb75f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,9 @@ else (CURSES_FOUND)
endif (ncursesw_FOUND)
if (WITH_LUA)
- pkg_search_module (lua REQUIRED lua5.3 lua-5.3 lua=5.3)
+ # FIXME: for "lua" we also need to check that it is < 5.4
+ # which doesn't seem to be possible with FindPkgConfig
+ pkg_search_module (lua REQUIRED lua5.3 lua-5.3 lua>=5.3)
list (APPEND project_libraries ${lua_LIBRARIES})
include_directories (${lua_INCLUDE_DIRS})
endif (WITH_LUA)