aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0446cc3..ec6c73b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,11 @@
-project('pdf-simple-sign', 'cpp', default_options : ['cpp_std=c++11'])
+project('pdf-simple-sign', 'cpp', default_options : ['cpp_std=c++11'],
+ version : '1.0')
+
+conf = configuration_data()
+conf.set('PROJECT_NAME', '"' + meson.project_name() + '"')
+conf.set('PROJECT_VERSION', '"' + meson.project_version() + '"')
+configure_file(output : 'config.h', configuration : conf)
+
cryptodep = dependency('libcrypto')
executable('pdf-simple-sign', 'pdf-simple-sign.cpp',
install : true,