aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-09-05 20:00:11 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-09-05 20:08:41 +0200
commit46fa50749f79e624a16adb081f7e5c5ff4a5b717 (patch)
tree0ad54eafa59b7246986dc59c6c677773d8244e90 /meson.build
parent796a9640d36328465cef66752a811eac5f7b3da5 (diff)
downloadpdf-simple-sign-46fa50749f79e624a16adb081f7e5c5ff4a5b717.tar.gz
pdf-simple-sign-46fa50749f79e624a16adb081f7e5c5ff4a5b717.tar.xz
pdf-simple-sign-46fa50749f79e624a16adb081f7e5c5ff4a5b717.zip
Add a --version option
And fix that --reservation was missing from the optstring.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0446cc3..ec6c73b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,11 @@
-project('pdf-simple-sign', 'cpp', default_options : ['cpp_std=c++11'])
+project('pdf-simple-sign', 'cpp', default_options : ['cpp_std=c++11'],
+ version : '1.0')
+
+conf = configuration_data()
+conf.set('PROJECT_NAME', '"' + meson.project_name() + '"')
+conf.set('PROJECT_VERSION', '"' + meson.project_version() + '"')
+configure_file(output : 'config.h', configuration : conf)
+
cryptodep = dependency('libcrypto')
executable('pdf-simple-sign', 'pdf-simple-sign.cpp',
install : true,