aboutsummaryrefslogtreecommitdiff
path: root/meson/packaging/meson.build
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-04-30 10:45:23 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-04-30 10:45:23 +0200
commite25a880883c43e8ffd52e56fe723a16af942d2c9 (patch)
tree6509d46e1adf31f1be65b0730ccc228ca82ff032 /meson/packaging/meson.build
parent9afcb337ada91f87aa1a566ec3feba1a12bc9287 (diff)
downloadliberty-e25a880883c43e8ffd52e56fe723a16af942d2c9.tar.gz
liberty-e25a880883c43e8ffd52e56fe723a16af942d2c9.tar.xz
liberty-e25a880883c43e8ffd52e56fe723a16af942d2c9.zip
Add packaging scripts for Meson
It probably doesn't belong here but I don't feel like creating another repository for this either yet.
Diffstat (limited to 'meson/packaging/meson.build')
-rw-r--r--meson/packaging/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson/packaging/meson.build b/meson/packaging/meson.build
new file mode 100644
index 0000000..d0b9cb2
--- /dev/null
+++ b/meson/packaging/meson.build
@@ -0,0 +1,11 @@
+# You need to prepare a configuration object with the required metadata
+packaging.set ('arch', target_machine.cpu_family ())
+packaging.set ('system', target_machine.system ())
+configure_file (input: 'meta.in', output: 'meta', configuration: packaging)
+
+# RPM is awful and I've given up on both manual generation (we'd have to either
+# include rpmrc data or generate fake noarch packages) and rpmbuild (just no)
+run_target ('deb',
+ command: [join_paths (meson.current_source_dir (), 'make-deb.sh')])
+run_target ('pacman',
+ command: [join_paths (meson.current_source_dir (), 'make-pacman.sh')])