From e25a880883c43e8ffd52e56fe723a16af942d2c9 Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Sun, 30 Apr 2017 10:45:23 +0200
Subject: Add packaging scripts for Meson
It probably doesn't belong here but I don't feel like creating another
repository for this either yet.
---
meson/packaging/meson.build | 11 +++++++++++
1 file changed, 11 insertions(+)
create mode 100644 meson/packaging/meson.build
(limited to 'meson/packaging/meson.build')
diff --git a/meson/packaging/meson.build b/meson/packaging/meson.build
new file mode 100644
index 0000000..d0b9cb2
--- /dev/null
+++ b/meson/packaging/meson.build
@@ -0,0 +1,11 @@
+# You need to prepare a configuration object with the required metadata
+packaging.set ('arch', target_machine.cpu_family ())
+packaging.set ('system', target_machine.system ())
+configure_file (input: 'meta.in', output: 'meta', configuration: packaging)
+
+# RPM is awful and I've given up on both manual generation (we'd have to either
+# include rpmrc data or generate fake noarch packages) and rpmbuild (just no)
+run_target ('deb',
+ command: [join_paths (meson.current_source_dir (), 'make-deb.sh')])
+run_target ('pacman',
+ command: [join_paths (meson.current_source_dir (), 'make-pacman.sh')])
--
cgit v1.2.3-70-g09d2