aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-01-25 18:06:42 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2017-01-25 18:12:18 +0100
commit66f1a6afa363c5495c38548298f2aeb87014b3cc (patch)
treeea6c18f3642f200d407721300f46151fd6a29613 /CMakeLists.txt
parent72a7cbdb1f5017475a331af3bba5169e56cc6a79 (diff)
downloadjson-rpc-shell-66f1a6afa363c5495c38548298f2aeb87014b3cc.tar.gz
json-rpc-shell-66f1a6afa363c5495c38548298f2aeb87014b3cc.tar.xz
json-rpc-shell-66f1a6afa363c5495c38548298f2aeb87014b3cc.zip
Fix OpenSSL 1.1 compatibility
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52b691d..465d8b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,8 @@ set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
find_package (Curses)
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED libcurl jansson)
+# Note that cURL can link to a different version of libssl than we do,
+# in which case the results are undefined
pkg_check_modules (libssl REQUIRED libssl libcrypto)
find_package (LibEV REQUIRED)
pkg_check_modules (ncursesw ncursesw)