aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96bcc73..6c34ca6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,9 @@ project (hex C)
cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
-if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- set (CMAKE_C_FLAGS_DEBUG
- "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-unused-function")
+if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -Wextra ${wdisabled}")
endif ()
# Version