aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-06-22 23:34:41 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-11-14 03:23:41 +0100
commitf075d11b0da12734891e4857d4589a2db9a2ae9d (patch)
tree778d562db3ee62ea68734ad60ce3b27f76f83bf7 /CMakeLists.txt
parent9206e1ea1dc5d17010bc1892adaddb8d144fe07e (diff)
downloadhex-f075d11b0da12734891e4857d4589a2db9a2ae9d.tar.gz
hex-f075d11b0da12734891e4857d4589a2db9a2ae9d.tar.xz
hex-f075d11b0da12734891e4857d4589a2db9a2ae9d.zip
Bump liberty, termo, fix compiler detection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96bcc73..6c34ca6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,9 @@ project (hex C)
cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
-if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- set (CMAKE_C_FLAGS_DEBUG
- "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-unused-function")
+if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -Wextra ${wdisabled}")
endif ()
# Version