aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-06-26 15:31:28 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-06-26 15:34:10 +0200
commitec713b633e0add828cdf410c10eee7b48717ba55 (patch)
treedf5e6775228818cc60d3a90ccf4bf92e100cf63b /meson.build
parent88234f8283de71e34a9bca427ed5fbc94839e6a4 (diff)
downloadfiv-ec713b633e0add828cdf410c10eee7b48717ba55.tar.gz
fiv-ec713b633e0add828cdf410c10eee7b48717ba55.tar.xz
fiv-ec713b633e0add828cdf410c10eee7b48717ba55.zip
Package the MSI from within a custom target
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 4a9b411..f809ebd 100644
--- a/meson.build
+++ b/meson.build
@@ -338,11 +338,7 @@ elif meson.is_cross_build()
msys2_root = meson.get_external_property('msys2_root')
meson.add_install_script('msys2-install.sh', msys2_root)
- # TODO: If we used DESTDIR instead of the prefix, this could probably
- # be a custom target that invokes "meson install --destdir $(pwd)/package"
- # through "meson compile -C builddir msi". Try it out, also in MSYS2.
- meson.add_install_script('msys2-package.sh', host_machine.cpu())
- configure_file(
+ wxs = configure_file(
input : 'fiv.wxs.in',
output : 'fiv.wxs',
configuration : configuration_data({
@@ -350,6 +346,16 @@ elif meson.is_cross_build()
'ProjectVersion' : meson.project_version(),
}),
)
+ custom_target('package',
+ output : 'fiv.msi',
+ command : [meson.current_source_dir() / 'msys2-package.sh',
+ host_machine.cpu(), 'fiv.msi', wxs],
+ env : ['MESON_BUILD_ROOT=' + meson.current_build_dir(),
+ 'MESON_SOURCE_ROOT=' + meson.current_source_dir()],
+ console : true,
+ build_always_stale : true,
+ build_by_default : false,
+ )
# This is the minimum to run targets from msys2-configure.sh builds.
meson.add_devenv({