aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-05-26 15:48:39 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-05-26 15:50:54 +0200
commitdf7c7b9f6b12a80f3a1de01c35e77ef2f919d28e (patch)
tree1cc0da275f93877fa7ee9dff20fe0a17867275d2 /meson.build
parentbb4b895cb5938712bd09fbd2b5f49bea811d7551 (diff)
downloadfiv-df7c7b9f6b12a80f3a1de01c35e77ef2f919d28e.tar.gz
fiv-df7c7b9f6b12a80f3a1de01c35e77ef2f919d28e.tar.xz
fiv-df7c7b9f6b12a80f3a1de01c35e77ef2f919d28e.zip
Fix build without tools
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7de6be2..9d1ceca 100644
--- a/meson.build
+++ b/meson.build
@@ -140,13 +140,14 @@ tiff_tables = custom_target('tiff-tables.h',
desktops = ['fiv.desktop', 'fiv-browse.desktop']
exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-io.c', 'fiv-context-menu.c',
'fiv-browser.c', 'fiv-sidebar.c', 'fiv-thumbnail.c', 'fiv-collection.c',
- 'xdg.c', gresources, rc, config,
+ 'xdg.c', tiff_tables, gresources, rc, config,
install : true,
dependencies : dependencies,
win_subsystem : 'windows',
)
if gdkpixbuf.found()
- executable('io-benchmark', 'fiv-io-benchmark.c', 'fiv-io.c', 'xdg.c',
+ executable('io-benchmark', 'fiv-io-benchmark.c', 'fiv-io.c',
+ 'xdg.c', tiff_tables,
build_by_default : false,
dependencies : [dependencies, gdkpixbuf])
endif