aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-17 13:45:42 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-17 13:49:15 +0100
commitdb7a28b187aa4ef8fee1a325bc493a16694a850b (patch)
tree96ebced6de94cdf3ad01b829a892d097f8c0691f /meson.build
parente8754f43a602f76fdbd35cdd24f9cfeeb4cdcf2b (diff)
downloadfiv-db7a28b187aa4ef8fee1a325bc493a16694a850b.tar.gz
fiv-db7a28b187aa4ef8fee1a325bc493a16694a850b.tar.xz
fiv-db7a28b187aa4ef8fee1a325bc493a16694a850b.zip
Add support for opening Xcursor files
Sadly, they don't have a canonical extension, and they don't show up in the browser. We might want to employ some level of sniffing. The first 16 bytes are enough to identify a lot.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1125cd9..5a89255 100644
--- a/meson.build
+++ b/meson.build
@@ -3,6 +3,7 @@ project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
# TODO(p): Use libraw_r later, when we start parallelizing/preloading.
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
+xcursor = dependency('xcursor', required : get_option('xcursor'))
gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
@@ -12,6 +13,7 @@ dependencies = [
dependency('pixman-1'),
libraw,
librsvg,
+ xcursor,
gdkpixbuf,
meson.get_compiler('c').find_library('m', required : false),
]
@@ -21,6 +23,7 @@ conf.set_quoted('PROJECT_NAME', meson.project_name())
conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
+conf.set('HAVE_XCURSOR', xcursor.found())
conf.set('HAVE_GDKPIXBUF', gdkpixbuf.found())
configure_file(
output : 'config.h',