aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-09-20 01:43:25 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-09-20 03:03:43 +0200
commitd7230fee0df687267fb6c29b5bb8b577de21ce4c (patch)
tree43e2571473954593328927f6b931e3f033b13a0b /meson.build
parente4d1e50c4ab405cecf9da1b5abfd8e0c92d5baef (diff)
downloadfiv-d7230fee0df687267fb6c29b5bb8b577de21ce4c.tar.gz
fiv-d7230fee0df687267fb6c29b5bb8b577de21ce4c.tar.xz
fiv-d7230fee0df687267fb6c29b5bb8b577de21ce4c.zip
Add a basic benchmarking tool
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index deb6b46..c38458d 100644
--- a/meson.build
+++ b/meson.build
@@ -22,6 +22,14 @@ executable('fastiv', 'fastiv.c', 'fastiv-view.c', 'fastiv-io.c',
install : true,
dependencies : [dependencies])
+# TODO(p): See fastiv_io_open(), consider optionally integrating this.
+gdk_pixbuf = dependency('gdk-pixbuf-2.0', required : false)
+if gdk_pixbuf.found()
+ executable('io-benchmark', 'fastiv-io-benchmark.c', 'fastiv-io.c',
+ build_by_default : false,
+ dependencies : [dependencies, gdk_pixbuf])
+endif
+
install_data('fastiv.desktop',
install_dir : get_option('datadir') + '/applications')
install_data('fastiv.svg',