aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-12-11 18:25:25 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-12-12 19:15:34 +0100
commitcaca14036c0b26df6eef4cdaef9cb7811545d52b (patch)
tree5e5aba2b9f8c24646a69965582545a90b06198b2 /meson.build
parentb868e76a1573c4f112477c8b38fbe1e82685ac88 (diff)
downloadfiv-caca14036c0b26df6eef4cdaef9cb7811545d52b.tar.gz
fiv-caca14036c0b26df6eef4cdaef9cb7811545d52b.tar.xz
fiv-caca14036c0b26df6eef4cdaef9cb7811545d52b.zip
Add preliminary direct support for WebP
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bbd0cc5..5538323 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,8 @@ endif
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
xcursor = dependency('xcursor', required : get_option('xcursor'))
+libwebp = dependency('libwebp', required : get_option('libwebp'))
+libwebpdecoder = dependency('libwebpdecoder', required : get_option('libwebp'))
libheif = dependency('libheif', required : get_option('libheif'))
libtiff = dependency('libtiff-4', required : get_option('libtiff'))
gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
@@ -29,6 +31,8 @@ dependencies = [
libraw,
librsvg,
xcursor,
+ libwebp,
+ libwebpdecoder,
libheif,
libtiff,
gdkpixbuf,
@@ -41,6 +45,7 @@ conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
conf.set('HAVE_XCURSOR', xcursor.found())
+conf.set('HAVE_LIBWEBP', libwebp.found())
conf.set('HAVE_LIBHEIF', libheif.found())
conf.set('HAVE_LIBTIFF', libtiff.found())
conf.set('HAVE_GDKPIXBUF', gdkpixbuf.found())