aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-12-23 16:12:25 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-12-23 16:12:35 +0100
commitc221a00c33067cc2c7f1019676de30d849536d6e (patch)
treeef236e443f42e0ebeee479f6730b76d7912c06d1 /meson.build
parent192ffa0de914a102003664e987b7acf07aa954a9 (diff)
downloadfiv-c221a00c33067cc2c7f1019676de30d849536d6e.tar.gz
fiv-c221a00c33067cc2c7f1019676de30d849536d6e.tar.xz
fiv-c221a00c33067cc2c7f1019676de30d849536d6e.zip
Improve MSI package names
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 82e7978..b364292 100644
--- a/meson.build
+++ b/meson.build
@@ -363,10 +363,12 @@ elif meson.is_cross_build()
'ProjectURL' : application_url,
}),
)
+ msi = meson.project_name() + '-' + meson.project_version() + \
+ '-' + host_machine.cpu() + '.msi'
custom_target('package',
- output : 'fiv.msi',
+ output : msi,
command : [meson.current_source_dir() / 'msys2-package.sh',
- host_machine.cpu(), 'fiv.msi', wxs],
+ host_machine.cpu(), msi, wxs],
env : ['MESON_BUILD_ROOT=' + meson.current_build_dir(),
'MESON_SOURCE_ROOT=' + meson.current_source_dir()],
console : true,