aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-12-11 14:40:10 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-12-11 16:11:25 +0100
commitac70c7724b1aa5020f358768451c08d4c77ac1ff (patch)
tree9dc5de2f5b2dd0a0da0d8f05ba9da9ebd9673d31 /meson.build
parent5f4090aaee642b905c8c1a1385bb975072fca1f6 (diff)
downloadfiv-ac70c7724b1aa5020f358768451c08d4c77ac1ff.tar.gz
fiv-ac70c7724b1aa5020f358768451c08d4c77ac1ff.tar.xz
fiv-ac70c7724b1aa5020f358768451c08d4c77ac1ff.zip
Add preliminary HEIF/AVIF support
The gdk-pixbuf plugin does not work here, for whatever reason. Moreover, close integration exposes higher bit depths, metadata, and auxiliary images. The library is awful and copylefted, but it's the only reasonable thing that works.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 34508c6..bbd0cc5 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,7 @@ endif
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
xcursor = dependency('xcursor', required : get_option('xcursor'))
+libheif = dependency('libheif', required : get_option('libheif'))
libtiff = dependency('libtiff-4', required : get_option('libtiff'))
gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
@@ -28,6 +29,7 @@ dependencies = [
libraw,
librsvg,
xcursor,
+ libheif,
libtiff,
gdkpixbuf,
meson.get_compiler('c').find_library('m', required : false),
@@ -39,6 +41,7 @@ conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
conf.set('HAVE_XCURSOR', xcursor.found())
+conf.set('HAVE_LIBHEIF', libheif.found())
conf.set('HAVE_LIBTIFF', libtiff.found())
conf.set('HAVE_GDKPIXBUF', gdkpixbuf.found())
configure_file(