aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-07-14 07:09:19 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-09-15 17:30:16 +0200
commit97781f6af4e3c84ab6fc6d574bc0b992cea3baa9 (patch)
treee4a8c82e0e53eefb1f0a8c90beb8172dd6a3a357 /meson.build
downloadfiv-97781f6af4e3c84ab6fc6d574bc0b992cea3baa9.tar.gz
fiv-97781f6af4e3c84ab6fc6d574bc0b992cea3baa9.tar.xz
fiv-97781f6af4e3c84ab6fc6d574bc0b992cea3baa9.zip
Initial commit
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..1295f1d
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,19 @@
+project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
+
+conf = configuration_data()
+conf.set_quoted('PROJECT_NAME', meson.project_name())
+conf.set_quoted('PROJECT_VERSION', meson.project_version())
+configure_file(
+ output : 'config.h',
+ configuration : conf,
+)
+
+dependencies = [
+ dependency('gtk+-3.0'),
+ dependency('libturbojpeg'),
+]
+
+# TODO(p): we need to create and install a .desktop file
+executable('fastiv', 'fastiv.c', 'fastiv-view.c',
+ install : true,
+ dependencies : [dependencies])