aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-20 20:55:24 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-20 22:02:02 +0100
commit8376ae9c4a6587cb664c353c1649fad666e1fbf2 (patch)
tree9006e1546f4f34aab4b203bf93033cdf2f08812d /meson.build
parent5ebfebb8fc08c7b5fc7fee85afeca270d712ae13 (diff)
downloadfiv-8376ae9c4a6587cb664c353c1649fad666e1fbf2.tar.gz
fiv-8376ae9c4a6587cb664c353c1649fad666e1fbf2.tar.xz
fiv-8376ae9c4a6587cb664c353c1649fad666e1fbf2.zip
Add some custom action buttons to the sidebar
So far they're inactive, and do not do anything. Change the icon for the current directory to stand out.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 61f3f52..970f81a 100644
--- a/meson.build
+++ b/meson.build
@@ -36,8 +36,15 @@ configure_file(
configuration : conf,
)
+gnome = import('gnome')
+resources = gnome.compile_resources('resources',
+ 'resources/resources.gresource.xml',
+ source_dir : 'resources',
+ c_name : 'resources',
+)
+
exe = executable('fastiv', 'fastiv.c', 'fastiv-view.c', 'fastiv-io.c',
- 'fastiv-browser.c', 'fastiv-sidebar.c', 'xdg.c',
+ 'fastiv-browser.c', 'fastiv-sidebar.c', 'xdg.c', resources,
install : true,
dependencies : [dependencies])