aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-10-10 09:31:13 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-10-17 15:31:55 +0200
commit72bf913f3d96a3260824361f9b410e32cc0d17e7 (patch)
tree4cc43dee1f94fbfb8415d9f40d812f978caeb0ca /meson.build
parente79574fd56a2401d5a05eb9ab0d8573c7f228fb8 (diff)
downloadfiv-72bf913f3d96a3260824361f9b410e32cc0d17e7.tar.gz
fiv-72bf913f3d96a3260824361f9b410e32cc0d17e7.tar.xz
fiv-72bf913f3d96a3260824361f9b410e32cc0d17e7.zip
Add a tool to find hot pixels
It works well for my Nikon. Note that hot pixels can be eliminated in the camera itself, when you run sensor cleaning immediately after a very long exposure of darkness.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 10e12d7..9c616ad 100644
--- a/meson.build
+++ b/meson.build
@@ -192,7 +192,7 @@ if get_option('tools').enabled()
cc.find_library('jq'), dependency('libpng'), dependency('libraw')]
tools_c_args = cc.get_supported_arguments(
'-Wno-unused-function', '-Wno-unused-parameter')
- foreach tool : ['info', 'pnginfo', 'rawinfo']
+ foreach tool : ['info', 'pnginfo', 'rawinfo', 'hotpixels']
executable(tool, 'tools/' + tool + '.c', tiff_tables,
dependencies : tools_dependencies,
c_args: tools_c_args)