aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-01-07 06:46:35 +0100
committerPřemysl Eric Janouch <p@janouch.name>2022-01-07 06:47:13 +0100
commit6869816cc4ab1330645044dabc6b3bfc6844e553 (patch)
tree71c4419450bd307e8327928aa829946bd4977fd7 /meson.build
parent8fdf9e2bc3433932878c9f6a15ea411f9a2b0f61 (diff)
downloadfiv-6869816cc4ab1330645044dabc6b3bfc6844e553.tar.gz
fiv-6869816cc4ab1330645044dabc6b3bfc6844e553.tar.xz
fiv-6869816cc4ab1330645044dabc6b3bfc6844e553.zip
Fix desktop file regeneration with certain AWKs
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c3d5a86..de1adfa 100644
--- a/meson.build
+++ b/meson.build
@@ -83,7 +83,7 @@ if gdkpixbuf.found()
dependencies : [dependencies, gdkpixbuf])
endif
-# XXX: With gdk-pixbuf, this even dependens on currently installed modules.
+# XXX: With gdk-pixbuf, this even depends on currently installed modules.
if meson.is_cross_build()
install_data('fiv.desktop',
install_dir : get_option('datadir') + '/applications')
@@ -93,7 +93,7 @@ else
output : 'fiv.desktop',
input : 'fiv.desktop',
command : ['sh', '-c', '''awk '/^MimeType=/ { $0 = "MimeType=";
- while ((exe " --list-supported-media-types" | getline type) > 0)
+ while (((exe " --list-supported-media-types") | getline type) > 0)
$0 = $0 type ";" } 1' "exe=$1" "$2"''', 'sh', exe, '@INPUT@'],
capture : true,
install : true,