aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-01-05 04:42:01 +0100
committerPřemysl Eric Janouch <p@janouch.name>2022-01-05 04:45:46 +0100
commit685defa68419654e875a7167a7b09d5398c497a9 (patch)
tree4af686449edc15156fc4f4ef278d8a55d1254ff9 /meson.build
parentb935b0baf868014d741bdbbf288c7b6a82fb0749 (diff)
downloadfiv-685defa68419654e875a7167a7b09d5398c497a9.tar.gz
fiv-685defa68419654e875a7167a7b09d5398c497a9.tar.xz
fiv-685defa68419654e875a7167a7b09d5398c497a9.zip
Rename the whole project shorter
There is no point in claiming speed, it turns out to be a strange focus to have, considering the amount of available innovations to make. The new name does not appear to be taken by anything important.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 50ac6f2..d862493 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
# vim: noet ts=4 sts=4 sw=4:
-project('fastiv', 'c',
+project('fiv', 'c',
default_options : ['c_std=gnu99', 'warning_level=2'],
version : '0.1.0')
add_project_arguments(
@@ -70,7 +70,7 @@ resources = gnome.compile_resources('resources',
c_name : 'resources',
)
-exe = executable('fastiv', 'fastiv.c', 'fiv-view.c', 'fiv-io.c',
+exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-io.c',
'fiv-browser.c', 'fiv-sidebar.c', 'fiv-thumbnail.c', 'xdg.c', resources,
install : true,
dependencies : [dependencies])
@@ -81,11 +81,11 @@ if gdkpixbuf.found()
dependencies : [dependencies, gdkpixbuf])
endif
-install_data('fastiv.desktop',
+install_data('fiv.desktop',
install_dir : get_option('datadir') + '/applications')
-install_data('fastiv-browse.desktop',
+install_data('fiv-browse.desktop',
install_dir : get_option('datadir') + '/applications')
-install_data('fastiv.svg',
+install_data('fiv.svg',
install_dir : get_option('datadir') + '/icons/hicolor/scalable/apps')
# TODO(p): Replace this with custom_target().
@@ -96,5 +96,5 @@ MimeType=$($1 --list-supported-media-types | tr "\\012" ";")
}" "$MESON_INSTALL_DESTDIR_PREFIX/$2"''',
'sh',
exe.full_path(),
- get_option('datadir') + '/applications/fastiv.desktop')
+ get_option('datadir') + '/applications/fiv.desktop')
endif