aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-26 21:31:13 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-28 02:20:23 +0100
commit666bfc0759b5be23980fb94f32809a1d26bde565 (patch)
tree0a5fbc183e1338822836c43b86e662e497672202 /meson.build
parentf1742ec7da04971c19790565aa633e0fd9c1b45f (diff)
downloadfiv-666bfc0759b5be23980fb94f32809a1d26bde565.tar.gz
fiv-666bfc0759b5be23980fb94f32809a1d26bde565.tar.xz
fiv-666bfc0759b5be23980fb94f32809a1d26bde565.zip
Support using libtiff directly
Multiple directories are read as multiple pages. The error handling is mildly questionable, as is libtiff.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1561d19..3780515 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,7 @@ add_project_arguments(
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
xcursor = dependency('xcursor', required : get_option('xcursor'))
+libtiff = dependency('libtiff-4', required : get_option('libtiff'))
gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
@@ -20,6 +21,7 @@ dependencies = [
libraw,
librsvg,
xcursor,
+ libtiff,
gdkpixbuf,
meson.get_compiler('c').find_library('m', required : false),
]
@@ -30,6 +32,7 @@ conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
conf.set('HAVE_XCURSOR', xcursor.found())
+conf.set('HAVE_LIBTIFF', libtiff.found())
conf.set('HAVE_GDKPIXBUF', gdkpixbuf.found())
configure_file(
output : 'config.h',