aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-01-26 21:58:18 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-01-28 01:48:28 +0100
commit604594a8f1d048b516120ba98eba71302e2043b4 (patch)
tree22e2923cadd1413503d1527bb10efbaaf1c09d81 /meson.build
parent9acab00bcc53d3adc52f1681d733e57dcb3c3f0d (diff)
downloadfiv-604594a8f1d048b516120ba98eba71302e2043b4.tar.gz
fiv-604594a8f1d048b516120ba98eba71302e2043b4.tar.xz
fiv-604594a8f1d048b516120ba98eba71302e2043b4.zip
Prepare for parallelized colour management
This rewrite is more or less necessary for: - colour-managed browser thumbnails, - asynchronous image loading, - turning fiv-io into a reusable library. Little CMS has a fairly terrible API in this regard.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2d854e7..bf18196 100644
--- a/meson.build
+++ b/meson.build
@@ -164,7 +164,7 @@ tiff_tables = custom_target('tiff-tables.h',
)
desktops = ['fiv.desktop', 'fiv-browse.desktop']
-iolib = static_library('fiv-io', 'fiv-io.c', 'fiv-io-profile.c', 'xdg.c',
+iolib = static_library('fiv-io', 'fiv-io.c', 'fiv-io-cmm.c', 'xdg.c',
tiff_tables,
dependencies : dependencies).extract_all_objects(recursive : true)
exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-context-menu.c',