aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-09-16 17:34:28 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-09-16 18:01:01 +0200
commit440a9a98409cef4e9ba3c8aa4cc2bfaeb8798b9f (patch)
tree720df17e956e393ec28d049ff9583008ff074dc8 /meson.build
parent913267724ab3d503a4c6dde4ce31ef6460749d4b (diff)
downloadfiv-440a9a98409cef4e9ba3c8aa4cc2bfaeb8798b9f.tar.gz
fiv-440a9a98409cef4e9ba3c8aa4cc2bfaeb8798b9f.tar.xz
fiv-440a9a98409cef4e9ba3c8aa4cc2bfaeb8798b9f.zip
Add an icon and a desktop file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b730544..2a13822 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
-# TODO(p): consider whether libraw_r would be appropriate
+# TODO(p): Use libraw_r later, when we start parallelizing/preloading.
libraw = dependency('libraw', required : get_option('libraw'))
dependencies = [
dependency('gtk+-3.0'),
@@ -17,7 +17,11 @@ configure_file(
configuration : conf,
)
-# TODO(p): we need to create and install a .desktop file
executable('fastiv', 'fastiv.c', 'fastiv-view.c',
install : true,
dependencies : [dependencies])
+
+install_data('fastiv.desktop',
+ install_dir : get_option('datadir') + '/applications')
+install_data('fastiv.svg',
+ install_dir : get_option('datadir') + '/icons/hicolor/scalable/apps')