aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-02-18 18:10:19 +0100
committerPřemysl Eric Janouch <p@janouch.name>2022-02-19 20:48:38 +0100
commit433ede4bf189a0be3d2313c0a9d9138a71eaa446 (patch)
tree4eb5d137d297e4c65894d9e065d51c914810b088 /meson.build
parent3ae8be8348ca2b636d906be9a434439ce43c300a (diff)
downloadfiv-433ede4bf189a0be3d2313c0a9d9138a71eaa446.tar.gz
fiv-433ede4bf189a0be3d2313c0a9d9138a71eaa446.tar.xz
fiv-433ede4bf189a0be3d2313c0a9d9138a71eaa446.zip
Add a lossless JPEG cropper
This is more of an MVP, as metadata probably need adjustments.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9ef54de..99cff0a 100644
--- a/meson.build
+++ b/meson.build
@@ -105,13 +105,21 @@ exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-io.c',
'fiv-browser.c', 'fiv-sidebar.c', 'fiv-thumbnail.c', 'xdg.c', resources,
install : true,
dependencies : [dependencies])
-
if gdkpixbuf.found()
executable('io-benchmark', 'fiv-io-benchmark.c', 'fiv-io.c', 'xdg.c',
build_by_default : false,
dependencies : [dependencies, gdkpixbuf])
endif
+jpegcrop = executable('fiv-jpegcrop', 'fiv-jpegcrop.c',
+ install : true,
+ dependencies : [
+ dependency('gtk+-3.0'),
+ dependency('libturbojpeg'),
+ ])
+install_data('fiv-jpegcrop.desktop',
+ install_dir : get_option('datadir') / 'applications')
+
# XXX: With gdk-pixbuf, this even depends on currently installed modules.
if meson.is_cross_build()
install_data('fiv.desktop',