aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-12-22 22:07:49 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-12-24 14:19:22 +0100
commit40c1f8327e1fdbd48492edd2631ec05c4ade3a8b (patch)
tree565e4b7ad8fb021399a3fe59de5e0b4922c5c98a /meson.build
parent6419209c9849238bf638c211875ff006211884eb (diff)
downloadfiv-40c1f8327e1fdbd48492edd2631ec05c4ade3a8b.tar.gz
fiv-40c1f8327e1fdbd48492edd2631ec05c4ade3a8b.tar.xz
fiv-40c1f8327e1fdbd48492edd2631ec05c4ade3a8b.zip
Use Little CMS for JPEG colour management
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index de58bd5..f3fae8c 100644
--- a/meson.build
+++ b/meson.build
@@ -15,6 +15,7 @@ if get_option('buildtype').startswith('debug')
endif
# TODO(p): Use libraw_r later, when we start parallelizing/preloading.
+lcms2 = dependency('lcms2', required : get_option('lcms2'))
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
xcursor = dependency('xcursor', required : get_option('xcursor'))
@@ -27,11 +28,14 @@ libtiff = dependency('libtiff-4', required : get_option('libtiff'))
gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
+ dependency('pixman-1'),
+
dependency('libturbojpeg'),
dependency('libjpeg', required : get_option('jpeg-qs')),
dependency('spng', version : '>=0.7.0',
default_options: 'default_library=static'),
- dependency('pixman-1'),
+
+ lcms2,
libraw,
librsvg,
xcursor,
@@ -50,6 +54,7 @@ conf.set_quoted('PROJECT_NAME', meson.project_name())
conf.set_quoted('PROJECT_VERSION', meson.project_version())
# TODO(p): Wrap it in a Meson subproject, try to enable SIMD.
conf.set('HAVE_JPEG_QS', get_option('jpeg-qs').enabled())
+conf.set('HAVE_LCMS2', lcms2.found())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
conf.set('HAVE_XCURSOR', xcursor.found())