aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-01-26 18:37:38 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-01-26 19:17:54 +0100
commit3c8a280546e3ec19c3246afada2d488880fc3222 (patch)
treefe95a502ea4b2ea9e20fcd1cea7045b1e67508e8 /meson.build
parent96189b70b85f939401a40364b222b91f905d291a (diff)
downloadfiv-3c8a280546e3ec19c3246afada2d488880fc3222.tar.gz
fiv-3c8a280546e3ec19c3246afada2d488880fc3222.tar.xz
fiv-3c8a280546e3ec19c3246afada2d488880fc3222.zip
Move colour management to its own compilation unit
Also make it apparent that CMM profiles are pointer types. This isn't all that pretty, but it's a necessary first step.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9c616ad..2d854e7 100644
--- a/meson.build
+++ b/meson.build
@@ -164,7 +164,8 @@ tiff_tables = custom_target('tiff-tables.h',
)
desktops = ['fiv.desktop', 'fiv-browse.desktop']
-iolib = static_library('fiv-io', 'fiv-io.c', 'xdg.c', tiff_tables,
+iolib = static_library('fiv-io', 'fiv-io.c', 'fiv-io-profile.c', 'xdg.c',
+ tiff_tables,
dependencies : dependencies).extract_all_objects(recursive : true)
exe = executable('fiv', 'fiv.c', 'fiv-view.c', 'fiv-context-menu.c',
'fiv-browser.c', 'fiv-sidebar.c', 'fiv-thumbnail.c', 'fiv-collection.c',