aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-12-22 10:59:03 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-12-22 14:20:39 +0100
commit2d4cab52b37c58c881e8bb7786adbe868f004a63 (patch)
tree7386bd3c94da4bc099c498f4b68feab8d7aaecd8 /meson.build
parent46edd4406c360ca85e83b7bec30ce115e186346f (diff)
downloadfiv-2d4cab52b37c58c881e8bb7786adbe868f004a63.tar.gz
fiv-2d4cab52b37c58c881e8bb7786adbe868f004a63.tar.xz
fiv-2d4cab52b37c58c881e8bb7786adbe868f004a63.zip
Integrate jpeg-quantsmooth
Also, don't pointlessly store JPEGs in an ARGB Cairo surface.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0cabcc4..de58bd5 100644
--- a/meson.build
+++ b/meson.build
@@ -28,6 +28,7 @@ gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
dependency('libturbojpeg'),
+ dependency('libjpeg', required : get_option('jpeg-qs')),
dependency('spng', version : '>=0.7.0',
default_options: 'default_library=static'),
dependency('pixman-1'),
@@ -47,6 +48,8 @@ dependencies = [
conf = configuration_data()
conf.set_quoted('PROJECT_NAME', meson.project_name())
conf.set_quoted('PROJECT_VERSION', meson.project_version())
+# TODO(p): Wrap it in a Meson subproject, try to enable SIMD.
+conf.set('HAVE_JPEG_QS', get_option('jpeg-qs').enabled())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
conf.set('HAVE_XCURSOR', xcursor.found())