aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-12 10:37:02 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-12 11:45:34 +0100
commit21b110a7d6151add6984def40b3b6b48ecb91c49 (patch)
treeec147838bf839143d66f749d73c2fae63806716d /meson.build
parentafc08df23461d8c8691c25edabf527dc41c29bcb (diff)
downloadfiv-21b110a7d6151add6984def40b3b6b48ecb91c49.tar.gz
fiv-21b110a7d6151add6984def40b3b6b48ecb91c49.tar.xz
fiv-21b110a7d6151add6984def40b3b6b48ecb91c49.zip
Use spng to load thumbnails
Speed matters here, and this makes us about 20 percent faster at loading large directories. Moreover, libpng's PNG_ALPHA_BROKEN is indeed broken. Thumbnails have a fairly fixed format, so there are very few practical corner cases that could have been missed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aaa33a8..1ec2346 100644
--- a/meson.build
+++ b/meson.build
@@ -7,7 +7,7 @@ gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
dependency('libturbojpeg'),
- dependency('libpng', version : '>=1.5.4'),
+ dependency('spng', version : '>=0.7.0'),
dependency('pixman-1'),
libraw,
librsvg,