aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-09 19:42:43 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-10 00:23:19 +0100
commit1c5cc5093937b9ea68bba8200f2d71eb613e2979 (patch)
treeeeb8740a898ccc16c4784e197fdef3302fc1b845 /meson.build
parent1e380f695a39db754c79126be632cbf9c5d46941 (diff)
downloadfiv-1c5cc5093937b9ea68bba8200f2d71eb613e2979.tar.gz
fiv-1c5cc5093937b9ea68bba8200f2d71eb613e2979.tar.xz
fiv-1c5cc5093937b9ea68bba8200f2d71eb613e2979.zip
Add very basic SVG support
We need to refactor, so that SVGs are pre-rendered on each change of scaling by librsvg directly, because some elements may be rasterized. It would be best to also support building against resvg.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4e1d299..d5acea1 100644
--- a/meson.build
+++ b/meson.build
@@ -2,12 +2,14 @@ project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
# TODO(p): Use libraw_r later, when we start parallelizing/preloading.
libraw = dependency('libraw', required : get_option('libraw'))
+librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
dependencies = [
dependency('gtk+-3.0'),
dependency('libturbojpeg'),
dependency('libpng', version : '>=1.5.4'),
dependency('pixman-1'),
libraw,
+ librsvg,
meson.get_compiler('c').find_library('m', required : false),
]
@@ -15,6 +17,7 @@ conf = configuration_data()
conf.set_quoted('PROJECT_NAME', meson.project_name())
conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
+conf.set('HAVE_LIBRSVG', librsvg.found())
configure_file(
output : 'config.h',
configuration : conf,