aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-11-10 21:33:30 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-11-10 21:34:15 +0100
commit192698b7bdfe04e9b6ef4ad4e022422f34a00a53 (patch)
tree44bedabda67d73493e110c69aaec212684e69b06 /meson.build
parent405f9758997e6399bb573f4fc1119e493fe9c195 (diff)
downloadfiv-192698b7bdfe04e9b6ef4ad4e022422f34a00a53.tar.gz
fiv-192698b7bdfe04e9b6ef4ad4e022422f34a00a53.tar.xz
fiv-192698b7bdfe04e9b6ef4ad4e022422f34a00a53.zip
Add support for defaulting to gdk-pixbuf
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d5acea1..aaa33a8 100644
--- a/meson.build
+++ b/meson.build
@@ -3,6 +3,7 @@ project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
# TODO(p): Use libraw_r later, when we start parallelizing/preloading.
libraw = dependency('libraw', required : get_option('libraw'))
librsvg = dependency('librsvg-2.0', required : get_option('librsvg'))
+gdkpixbuf = dependency('gdk-pixbuf-2.0', required : get_option('gdk-pixbuf'))
dependencies = [
dependency('gtk+-3.0'),
dependency('libturbojpeg'),
@@ -18,6 +19,7 @@ conf.set_quoted('PROJECT_NAME', meson.project_name())
conf.set_quoted('PROJECT_VERSION', meson.project_version())
conf.set('HAVE_LIBRAW', libraw.found())
conf.set('HAVE_LIBRSVG', librsvg.found())
+conf.set('HAVE_GDKPIXBUF', gdkpixbuf.found())
configure_file(
output : 'config.h',
configuration : conf,