aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-06-27 19:04:18 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-06-27 19:04:48 +0200
commit117422ade5a2544f3f66fd403b2ec5effef64c6a (patch)
tree56e8e50fce1ae51ca3039e9915fb584dbd8173e7 /meson.build
parent8ff33e6b63a2fc0201c4dd3d72f3e961199d731c (diff)
downloadfiv-117422ade5a2544f3f66fd403b2ec5effef64c6a.tar.gz
fiv-117422ade5a2544f3f66fd403b2ec5effef64c6a.tar.xz
fiv-117422ade5a2544f3f66fd403b2ec5effef64c6a.zip
Fix build instructions, add .deb generation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4bdca2e..7d9dc41 100644
--- a/meson.build
+++ b/meson.build
@@ -335,6 +335,16 @@ if not win32
if not meson.is_cross_build()
meson.add_install_script(updater, skip_if_destdir : dynamic_desktops)
endif
+
+ # Quick and dirty package generation, lacking dependencies.
+ packaging = configuration_data({
+ 'name' : meson.project_name(),
+ 'version' : meson.project_version(),
+ 'summary' : 'Image viewer',
+ 'author' : 'Přemysl Eric Janouch',
+ })
+
+ subdir('submodules/liberty/meson/packaging')
elif meson.is_cross_build()
# Note that even compiling /from within MSYS2/ can still be a cross-build.
msys2_root = meson.get_external_property('msys2_root')