aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-06-22 23:34:51 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-06-26 02:10:31 +0200
commit089c90004ba8f2af9574e3982b20a4b6cb2ab2f1 (patch)
treeb10b84635ec98c89f1c0656be01d70e494366fda /meson.build
parent19913a5e4880503dd06a73c03584e77d3cf504a0 (diff)
downloadfiv-089c90004ba8f2af9574e3982b20a4b6cb2ab2f1.tar.gz
fiv-089c90004ba8f2af9574e3982b20a4b6cb2ab2f1.tar.xz
fiv-089c90004ba8f2af9574e3982b20a4b6cb2ab2f1.zip
Produce a basic Windows installer package
We're very early adopters of msitools' new UI feature, so this doesn't work on MSYS2 directly yet due to an old version.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed3acbe..4a9b411 100644
--- a/meson.build
+++ b/meson.build
@@ -338,6 +338,19 @@ elif meson.is_cross_build()
msys2_root = meson.get_external_property('msys2_root')
meson.add_install_script('msys2-install.sh', msys2_root)
+ # TODO: If we used DESTDIR instead of the prefix, this could probably
+ # be a custom target that invokes "meson install --destdir $(pwd)/package"
+ # through "meson compile -C builddir msi". Try it out, also in MSYS2.
+ meson.add_install_script('msys2-package.sh', host_machine.cpu())
+ configure_file(
+ input : 'fiv.wxs.in',
+ output : 'fiv.wxs',
+ configuration : configuration_data({
+ 'ProjectName' : meson.project_name(),
+ 'ProjectVersion' : meson.project_version(),
+ }),
+ )
+
# This is the minimum to run targets from msys2-configure.sh builds.
meson.add_devenv({
'WINEPATH' : msys2_root / 'bin',