aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-05-25 03:55:25 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-05-26 13:30:22 +0200
commit0359ddf99f3940794d51c206a30d51eac4c2f1d2 (patch)
treee52384071b4711bb634fb0e784d2e327f9b97a01 /meson.build
parenta93fc3f88dd73a87cf889b9a161966d55edb1fde (diff)
downloadfiv-0359ddf99f3940794d51c206a30d51eac4c2f1d2.tar.gz
fiv-0359ddf99f3940794d51c206a30d51eac4c2f1d2.tar.xz
fiv-0359ddf99f3940794d51c206a30d51eac4c2f1d2.zip
Add a tool to extract LibRaw file information
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8571101..7de6be2 100644
--- a/meson.build
+++ b/meson.build
@@ -164,10 +164,12 @@ jpegcrop = executable('fiv-jpegcrop', 'fiv-jpegcrop.c', rc, config,
if get_option('tools').enabled()
# libjq 1.6 lacks a pkg-config file, and there is no release in sight.
# libjq 1.6 is required.
- tools_dependencies = [cc.find_library('jq'), dependency('libpng')]
+ tools_dependencies = [
+ cc.find_library('jq'), dependency('libpng'), dependency('libraw')]
tools_c_args = cc.get_supported_arguments(
'-Wno-unused-function', '-Wno-unused-parameter')
- foreach tool : ['pnginfo', 'jpeginfo', 'tiffinfo', 'webpinfo', 'bmffinfo']
+ foreach tool : [
+ 'pnginfo', 'rawinfo', 'jpeginfo', 'tiffinfo', 'webpinfo', 'bmffinfo']
executable(tool, 'tools/' + tool + '.c', tiff_tables,
dependencies : tools_dependencies,
c_args: tools_c_args)