aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8559b18..4de1ad2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,9 +148,12 @@ include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
# Generate IRC replies--we need a custom target because of the multiple outputs
add_custom_command (OUTPUT xD-replies.c xD.msg
- COMMAND env LC_ALL=C awk -f ${PROJECT_SOURCE_DIR}/xD-gen-replies.awk
- > xD-replies.c < ${PROJECT_SOURCE_DIR}/xD-replies
- DEPENDS ${PROJECT_SOURCE_DIR}/xD-replies
+ COMMAND env LC_ALL=C awk
+ -f ${PROJECT_SOURCE_DIR}/xD-gen-replies.awk
+ ${PROJECT_SOURCE_DIR}/xD-replies > xD-replies.c
+ DEPENDS
+ ${PROJECT_SOURCE_DIR}/xD-gen-replies.awk
+ ${PROJECT_SOURCE_DIR}/xD-replies
COMMENT "Generating files from the list of server numerics")
add_custom_target (replies DEPENDS ${PROJECT_BINARY_DIR}/xD-replies.c)