aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-08-29 06:02:54 +0200
committerPřemysl Eric Janouch <p@janouch.name>2022-08-29 06:07:49 +0200
commitecebeace0ea28f243045bdee1002530028846fe8 (patch)
tree20b4408449d312ae55eff3ecc2afd4b222dc84ae /CMakeLists.txt
parentca33adeeeee56262b95a6ff1339227bfc90e0a82 (diff)
downloadxK-ecebeace0ea28f243045bdee1002530028846fe8.tar.gz
xK-ecebeace0ea28f243045bdee1002530028846fe8.tar.xz
xK-ecebeace0ea28f243045bdee1002530028846fe8.zip
Don't wrap xD-gen-replies in a shell script
AWK doesn't seem to be that friendly to shebangs, so let env, also required for changing LC_ALL, locate it in PATH.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b403f3..8559b18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,7 +148,7 @@ include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
# Generate IRC replies--we need a custom target because of the multiple outputs
add_custom_command (OUTPUT xD-replies.c xD.msg
- COMMAND ${PROJECT_SOURCE_DIR}/xD-gen-replies.sh
+ COMMAND env LC_ALL=C awk -f ${PROJECT_SOURCE_DIR}/xD-gen-replies.awk
> xD-replies.c < ${PROJECT_SOURCE_DIR}/xD-replies
DEPENDS ${PROJECT_SOURCE_DIR}/xD-replies
COMMENT "Generating files from the list of server numerics")