aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2018-01-07 05:45:34 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2018-01-07 17:37:19 +0100
commitdc47b16034df32a1a04b0322f1cc51c055986099 (patch)
tree3d57fd661f6584db8d8eb7c7bbc19181cec0d3f6 /CMakeLists.txt
parentd0f19f8be3e33198d36d68c845a1bd965f4c8f74 (diff)
downloadxK-dc47b16034df32a1a04b0322f1cc51c055986099.tar.gz
xK-dc47b16034df32a1a04b0322f1cc51c055986099.tar.xz
xK-dc47b16034df32a1a04b0322f1cc51c055986099.zip
Bump liberty, avoid fall-through warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07f5dc3..fa0fe2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,7 @@ option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
# -Wunused-function is pretty annoying here, as everything is static
- set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (wdisabled "-Wno-unused-function")
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra ${wdisabled}")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)