aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-09-02 19:05:20 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-09-02 20:00:09 +0200
commitba1c2357af62a61e8084d77783868a10815b8556 (patch)
tree8ea980d4af7736007a9b9c78ccfed76f1892ff2d /CMakeLists.txt
parenta48023553ec7a0133e0a7bed20e0271ceb1acfbd (diff)
downloadxK-ba1c2357af62a61e8084d77783868a10815b8556.tar.gz
xK-ba1c2357af62a61e8084d77783868a10815b8556.tar.xz
xK-ba1c2357af62a61e8084d77783868a10815b8556.zip
degesch: fix Lua 5.4 build
Not sure about how well it works yet. Lua 5.3 is still made preferential by the order of pkgconfig lookup.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf41327..7f5ee6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,7 +85,7 @@ include_directories (${libffi_INCLUDE_DIRS})
link_directories (${libffi_LIBRARY_DIRS})
# FIXME: other Lua versions may be acceptable, don't know yet
-pkg_search_module (lua lua53 lua5.3 lua-5.3 lua>=5.3)
+pkg_search_module (lua lua53 lua5.3 lua-5.3 lua54 lua5.4 lua-5.4 lua>=5.3)
option (WITH_LUA "Enable support for Lua plugins" ${lua_FOUND})
if (WITH_LUA)