aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-12-09 00:53:56 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-01-04 01:12:42 +0100
commitaeb047260fefa187f5b2c5c740280c81b9ccb8f4 (patch)
tree68871219f216772b1a441f1a64ee2719d6be27a5 /CMakeLists.txt
parent28fec6d4a6a30e2fdb5394e90673e60f7c46234b (diff)
downloadxK-aeb047260fefa187f5b2c5c740280c81b9ccb8f4.tar.gz
xK-aeb047260fefa187f5b2c5c740280c81b9ccb8f4.tar.xz
xK-aeb047260fefa187f5b2c5c740280c81b9ccb8f4.zip
Bump liberty, enable TLS SNI
Involves some rewrites to fit the new APIs. SNI has been implemented Mostly just because we can, I don't think it's widely in use and kike doesn't support this feature of the protocol either.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca76dfa..2d25f6d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,9 @@ set (project_VERSION "${project_VERSION}.${project_VERSION_MINOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
# Dependencies
+set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/liberty/cmake)
+include (AddThreads)
+
find_package (Curses)
find_package (PkgConfig REQUIRED)
pkg_check_modules (libssl REQUIRED libssl libcrypto)
@@ -52,10 +55,9 @@ if (WITH_LUA)
link_directories (${lua_LIBRARY_DIRS})
endif (WITH_LUA)
-# -lpthread is only there for debugging (gdb & errno)
# -lrt is only for glibc < 2.17
# -liconv may or may not be a part of libc
-foreach (extra iconv rt pthread)
+foreach (extra iconv rt)
find_library (extra_lib_${extra} ${extra})
if (extra_lib_${extra})
list (APPEND project_libraries ${extra})
@@ -114,24 +116,31 @@ set_source_files_properties (${PROJECT_BINARY_DIR}/kike-replies.c
# Build
add_executable (zyklonb zyklonb.c ${common_sources} ${common_headers})
target_link_libraries (zyklonb ${project_libraries})
+add_threads (zyklonb)
add_executable (degesch degesch.c kike-replies.c
${common_sources} ${common_headers})
target_link_libraries (degesch ${project_libraries})
+add_threads (degesch)
add_executable (kike kike.c kike-replies.c ${common_sources} ${common_headers})
target_link_libraries (kike ${project_libraries})
+add_threads (kike)
# Tests
function (make_tests_for target_name)
get_target_property (sources ${target_name} SOURCES)
get_target_property (libraries ${target_name} LINK_LIBRARIES)
+ get_target_property (options ${target_name} COMPILE_OPTIONS)
set (test test-${target_name})
add_executable (${test} ${sources})
target_link_libraries (${test} ${libraries})
+ set_target_properties (${test} PROPERTIES
+ COMPILE_DEFINITIONS TESTING
+ COMPILE_OPTIONS ${options})
+
add_test (NAME ${test} COMMAND ${test})
- set_target_properties (${test} PROPERTIES COMPILE_DEFINITIONS TESTING)
endfunction (make_tests_for)
include (CTest)