aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p@janouch.name>2020-04-06 01:44:17 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-09-02 19:37:26 +0200
commit722fc48a30da39f859bceb00123aaf9fed9b0995 (patch)
tree4d0146e6a3ed4813ffcba7f0b8dc94aae4a0aadb /CMakeLists.txt
parent6287e20919b30b566de89a05863f74e9a882a98b (diff)
downloadxK-722fc48a30da39f859bceb00123aaf9fed9b0995.tar.gz
xK-722fc48a30da39f859bceb00123aaf9fed9b0995.tar.xz
xK-722fc48a30da39f859bceb00123aaf9fed9b0995.zip
CMakeLists.txt: add a comment
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1c567d..0e74411 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,8 @@ set (project_version "0.9.7")
# Try to append commit ID if it follows a version tag. It might be nicer if
# we could also detect dirty worktrees but that's very hard to get right.
+# If we didn't need this for CPack, we could use add_custom_command to generate
+# a version source/include file.
find_package (Git)
set (git_head "${PROJECT_SOURCE_DIR}/.git/HEAD")
if (GIT_FOUND AND EXISTS "${git_head}")