aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-11-21 22:47:52 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-11-21 22:47:52 +0100
commit71f3532e04e5c76327363a3fd36b506f54e5043d (patch)
tree8ed10c749ba0b9a3db62e0150e739dfacddc811c /CMakeLists.txt
parentd135728424dad963f789f2362f794ee393a11823 (diff)
downloadxK-71f3532e04e5c76327363a3fd36b506f54e5043d.tar.gz
xK-71f3532e04e5c76327363a3fd36b506f54e5043d.tar.xz
xK-71f3532e04e5c76327363a3fd36b506f54e5043d.zip
degesch: add the first Lua plugin to distribution
This required separate plugin directories for both pluginized executables.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64bb667..2e8a2f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,7 +94,8 @@ set (HAVE_EDITLINE "${WANT_LIBEDIT}")
set (HAVE_LUA "${WITH_LUA}")
include (GNUInstallDirs)
-set (plugin_dir ${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME})
+# ZyklonB is currently an odd duck but degesch follows normal XDG rules
+set (zyklonb_plugin_dir ${CMAKE_INSTALL_LIBDIR}/zyklonb/plugins)
configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
@@ -138,10 +139,10 @@ add_custom_target (clang-tidy
# Installation
install (TARGETS zyklonb degesch kike DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
-
-foreach (plugin coin eval script youtube ${plugins})
- install (FILES plugins/${plugin} DESTINATION ${plugin_dir})
-endforeach (plugin)
+install (DIRECTORY plugins/zyklonb/
+ DESTINATION ${zyklonb_plugin_dir} USE_SOURCE_PERMISSIONS)
+install (DIRECTORY plugins/degesch/
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/degesch/plugins)
# Generate documentation from program help
find_program (HELP2MAN_EXECUTABLE help2man)