aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-12-09 01:30:51 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-12-09 21:07:01 +0100
commit6a72c7382bdd18c4e25ec528299f3c27ec3b9468 (patch)
treefd01a2029770403cd861f0035e036d8262f9aaee /CMakeLists.txt
parent86d7b7aed52c66d12f361a3ee8dc7a0eb419bdbc (diff)
downloadxK-6a72c7382bdd18c4e25ec528299f3c27ec3b9468.tar.gz
xK-6a72c7382bdd18c4e25ec528299f3c27ec3b9468.tar.xz
xK-6a72c7382bdd18c4e25ec528299f3c27ec3b9468.zip
Fix Travis CI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 296a0f4..11e615f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,6 +127,12 @@ function (make_tests_for target_name)
get_target_property (sources ${target_name} SOURCES)
get_target_property (libraries ${target_name} LINK_LIBRARIES)
+ # Unfortunately the property is a 2.8.11 feature however we need to
+ # support at least 2.8.7 for now because of Travis CI
+ if (NOT libraries)
+ set (libraries ${project_libraries})
+ endif (NOT libraries)
+
set (test test-${target_name})
add_executable (${test} ${sources})
target_link_libraries (${test} ${libraries})